linux/3.2: build mdio_register_board_info into the kernel if PHYLIB is selected
[openwrt/svn-archive/archive.git] / target / linux / generic / patches-3.2 / 724-phy_ar8216.patch
index 7a51dccee8fff6bc3db8d899221a2954c66caf27..79169db74d6d7fa584c66f46126aa6d959e108eb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -116,6 +116,10 @@ config IP17XX_PHY
+@@ -120,6 +120,10 @@ config IP17XX_PHY
        tristate "Driver for IC+ IP17xx switches"
        select SWCONFIG
  
@@ -13,7 +13,7 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -18,6 +18,7 @@ obj-$(CONFIG_ADM6996_PHY)    += adm6996.o
+@@ -20,6 +20,7 @@ obj-$(CONFIG_ADM6996_PHY)    += adm6996.o
  obj-$(CONFIG_MVSWITCH_PHY)    += mvswitch.o
  obj-$(CONFIG_IP17XX_PHY)      += ip17xx.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o