[ifxmips] add register definitions for ebu
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / Makefile
index de982abf172e7f94d785a2e939a30d1246283cbd..addeef681096f7124698a2ba424d3273af844391 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.26.5
+FEATURES:=squashfs jffs2 atm
+
+LINUX_VERSION:=2.6.30.10
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips
+DEFAULT_PACKAGES+=kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers