rfkill config cleanup
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / Makefile
index 3328960243f0bfdc47bfe4a3554c580b65200832..eee0d44e919124d8d8f016091d5bec9de37c7200 100644 (file)
@@ -10,9 +10,8 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2
-SUBTARGETS:=generic nfs
-LINUX_VERSION:=2.6.26.8
-#LINUX_VERSION:=2.6.27.11
+
+LINUX_VERSION:=2.6.28.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
@@ -21,4 +20,11 @@ define Target/Description
        Build firmware images for Infineon Mips Controllers
 endef
 
+ifeq ($(KERNEL_PATCHVER),2.6.28)
+  define Kernel/Prepare
+       $(call Kernel/Prepare/Default)
+       mv $(LINUX_DIR)/include/asm-mips/* $(LINUX_DIR)/arch/mips/include/asm/
+  endef
+endif
+
 $(eval $(call BuildTarget))