compile libnl with -ffunction-sections to make binaries that use genl smaller
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / image / u-boot / Makefile
index c92a1a3c5bdd6b20a9a5549fda02da9e80e20315..dcba5ac45ad1516dcfe69567e7808f9f6795d75c 100644 (file)
@@ -22,10 +22,12 @@ include $(INCLUDE_DIR)/package.mk
 
 define Build/Compile
        cp -r ./files/* $(PKG_BUILD_DIR)
+       find $(PKG_BUILD_DIR) -name .svn | $(XARGS) rm -rf
        cd $(PKG_BUILD_DIR);chmod a+x build_danube.sh;./build_danube.sh
 endef
 
 define Build/InstallDev
+       mkdir -p $(BIN_DIR)
        dd if=$(PKG_BUILD_DIR)/u-boot.ifx of=$(BIN_DIR)/u-boot.ifx bs=64k conv=sync
 endef