[kernel] update to 2.6.25.12
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / patches / 100-board.patch
index 60d2fe7372acab51c86ce84b2cd28c48efc00bd5..0e82af76b26adad9f364f3e6c3b21c06f0773691 100644 (file)
@@ -1,13 +1,11 @@
-Index: linux-2.6.25.4/arch/mips/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/Kconfig
-+++ linux-2.6.25.4/arch/mips/Kconfig
-@@ -78,6 +78,21 @@ config MIPS_COBALT
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -78,6 +78,21 @@
        select SYS_SUPPORTS_LITTLE_ENDIAN
        select GENERIC_HARDIRQS_NO__DO_IRQ
  
 +config IFXMIPS
-+      bool "IFXMips support"
++      bool "Infineon Twinpass, Danube, Amazon-SE"
 +      select DMA_NONCOHERENT
 +      select IRQ_CPU
 +      select CEVT_R4K
@@ -18,13 +16,13 @@ Index: linux-2.6.25.4/arch/mips/Kconfig
 +      select SYS_SUPPORTS_32BIT_KERNEL
 +      select SYS_HAS_EARLY_PRINTK
 +      select HW_HAS_PCI
-+      select GENERIC_GPIO 
++      select GENERIC_GPIO
 +      select SWAP_IO_SPACE
 +
  config MACH_DECSTATION
        bool "DECstations"
        select BOOT_ELF32
-@@ -693,6 +706,7 @@ source "arch/mips/sibyte/Kconfig"
+@@ -693,6 +708,7 @@
  source "arch/mips/tx4927/Kconfig"
  source "arch/mips/tx4938/Kconfig"
  source "arch/mips/vr41xx/Kconfig"
@@ -32,28 +30,24 @@ Index: linux-2.6.25.4/arch/mips/Kconfig
  
  endmenu
  
-Index: linux-2.6.25.4/arch/mips/Makefile
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/Makefile
-+++ linux-2.6.25.4/arch/mips/Makefile
-@@ -282,6 +282,13 @@ core-$(CONFIG_MIPS_COBALT)        += arch/mips/
- cflags-$(CONFIG_MIPS_COBALT)  += -Iinclude/asm-mips/mach-cobalt
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -283,6 +283,13 @@
  load-$(CONFIG_MIPS_COBALT)    += 0xffffffff80080000
  
-+# 
+ #
 +# Infineon IFXMIPS
-+# 
++#
 +core-$(CONFIG_IFXMIPS) += arch/mips/ifxmips/
 +cflags-$(CONFIG_IFXMIPS)   += -Iinclude/asm-mips/mach-ifxmips
 +load-$(CONFIG_IFXMIPS) += 0xffffffff80002000
 +
- #
++#
  # DECstation family
  #
-Index: linux-2.6.25.4/include/asm-mips/bootinfo.h
-===================================================================
---- linux-2.6.25.4.orig/include/asm-mips/bootinfo.h
-+++ linux-2.6.25.4/include/asm-mips/bootinfo.h
+ core-$(CONFIG_MACH_DECSTATION)        += arch/mips/dec/
+--- a/include/asm-mips/bootinfo.h
++++ b/include/asm-mips/bootinfo.h
 @@ -94,6 +94,12 @@
  #define MACH_MSP7120_FPGA       5     /* PMC-Sierra MSP7120 Emulation */
  #define MACH_MSP_OTHER        255     /* PMC-Sierra unknown board type */
@@ -67,11 +61,9 @@ Index: linux-2.6.25.4/include/asm-mips/bootinfo.h
  #define CL_SIZE                       COMMAND_LINE_SIZE
  
  extern char *system_type;
-Index: linux-2.6.25.4/arch/mips/kernel/traps.c
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/kernel/traps.c
-+++ linux-2.6.25.4/arch/mips/kernel/traps.c
-@@ -1379,6 +1379,7 @@ void __cpuinit per_cpu_trap_init(void)
+--- a/arch/mips/kernel/traps.c
++++ b/arch/mips/kernel/traps.c
+@@ -1379,6 +1379,7 @@
         */
        if (cpu_has_mips_r2) {
                cp0_compare_irq = (read_c0_intctl() >> 29) & 7;
@@ -79,3 +71,10 @@ Index: linux-2.6.25.4/arch/mips/kernel/traps.c
                cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
                if (cp0_perfcount_irq == cp0_compare_irq)
                        cp0_perfcount_irq = -1;
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -48,3 +48,4 @@
+ obj-$(CONFIG_VICTOR_MPC30X)   += fixup-mpc30x.o
+ obj-$(CONFIG_ZAO_CAPCELLA)    += fixup-capcella.o
+ obj-$(CONFIG_WR_PPMC)         += fixup-wrppmc.o
++obj-$(CONFIG_IFXMIPS)         += pci-ifxmips.o ops-ifxmips.o