[kernel] update to 2.6.25.12
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / patches / 100-board.patch
index 79d18cadc35484098811c652d826e3e0f7cd29a6..0e82af76b26adad9f364f3e6c3b21c06f0773691 100644 (file)
@@ -1,13 +1,11 @@
-Index: linux-2.6.25.7/arch/mips/Kconfig
-===================================================================
---- linux-2.6.25.7.orig/arch/mips/Kconfig      2008-06-18 00:28:54.000000000 +0200
-+++ linux-2.6.25.7/arch/mips/Kconfig   2008-06-18 00:35:50.000000000 +0200
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
 @@ -78,6 +78,21 @@
        select SYS_SUPPORTS_LITTLE_ENDIAN
        select GENERIC_HARDIRQS_NO__DO_IRQ
  
 +config IFXMIPS
-+      bool "IFXMips support"
++      bool "Infineon Twinpass, Danube, Amazon-SE"
 +      select DMA_NONCOHERENT
 +      select IRQ_CPU
 +      select CEVT_R4K
@@ -32,10 +30,8 @@ Index: linux-2.6.25.7/arch/mips/Kconfig
  
  endmenu
  
-Index: linux-2.6.25.7/arch/mips/Makefile
-===================================================================
---- linux-2.6.25.7.orig/arch/mips/Makefile     2008-06-18 00:29:07.000000000 +0200
-+++ linux-2.6.25.7/arch/mips/Makefile  2008-06-18 00:35:42.000000000 +0200
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
 @@ -283,6 +283,13 @@
  load-$(CONFIG_MIPS_COBALT)    += 0xffffffff80080000
  
@@ -50,10 +46,8 @@ Index: linux-2.6.25.7/arch/mips/Makefile
  # DECstation family
  #
  core-$(CONFIG_MACH_DECSTATION)        += arch/mips/dec/
-Index: linux-2.6.25.7/include/asm-mips/bootinfo.h
-===================================================================
---- linux-2.6.25.7.orig/include/asm-mips/bootinfo.h    2008-06-18 00:28:54.000000000 +0200
-+++ linux-2.6.25.7/include/asm-mips/bootinfo.h 2008-06-18 00:29:08.000000000 +0200
+--- a/include/asm-mips/bootinfo.h
++++ b/include/asm-mips/bootinfo.h
 @@ -94,6 +94,12 @@
  #define MACH_MSP7120_FPGA       5     /* PMC-Sierra MSP7120 Emulation */
  #define MACH_MSP_OTHER        255     /* PMC-Sierra unknown board type */
@@ -67,10 +61,8 @@ Index: linux-2.6.25.7/include/asm-mips/bootinfo.h
  #define CL_SIZE                       COMMAND_LINE_SIZE
  
  extern char *system_type;
-Index: linux-2.6.25.7/arch/mips/kernel/traps.c
-===================================================================
---- linux-2.6.25.7.orig/arch/mips/kernel/traps.c       2008-06-18 00:28:54.000000000 +0200
-+++ linux-2.6.25.7/arch/mips/kernel/traps.c    2008-06-18 00:29:08.000000000 +0200
+--- a/arch/mips/kernel/traps.c
++++ b/arch/mips/kernel/traps.c
 @@ -1379,6 +1379,7 @@
         */
        if (cpu_has_mips_r2) {
@@ -79,10 +71,8 @@ Index: linux-2.6.25.7/arch/mips/kernel/traps.c
                cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
                if (cp0_perfcount_irq == cp0_compare_irq)
                        cp0_perfcount_irq = -1;
-Index: linux-2.6.25.7/arch/mips/pci/Makefile
-===================================================================
---- linux-2.6.25.7.orig/arch/mips/pci/Makefile 2008-06-18 00:34:49.000000000 +0200
-+++ linux-2.6.25.7/arch/mips/pci/Makefile      2008-06-18 00:35:03.000000000 +0200
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
 @@ -48,3 +48,4 @@
  obj-$(CONFIG_VICTOR_MPC30X)   += fixup-mpc30x.o
  obj-$(CONFIG_ZAO_CAPCELLA)    += fixup-capcella.o