[kernel] update to 2.6.25.12
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / patches / 100-board.patch
index eea8c159d259441afbaa0e130faa11499953febb..0e82af76b26adad9f364f3e6c3b21c06f0773691 100644 (file)
@@ -5,7 +5,7 @@
        select GENERIC_HARDIRQS_NO__DO_IRQ
  
 +config IFXMIPS
-+      bool "IFXMips support"
++      bool "Infineon Twinpass, Danube, Amazon-SE"
 +      select DMA_NONCOHERENT
 +      select IRQ_CPU
 +      select CEVT_R4K
@@ -16,7 +16,7 @@
 +      select SYS_SUPPORTS_32BIT_KERNEL
 +      select SYS_HAS_EARLY_PRINTK
 +      select HW_HAS_PCI
-+      select GENERIC_GPIO 
++      select GENERIC_GPIO
 +      select SWAP_IO_SPACE
 +
  config MACH_DECSTATION
  
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -282,6 +282,13 @@
- cflags-$(CONFIG_MIPS_COBALT)  += -Iinclude/asm-mips/mach-cobalt
+@@ -283,6 +283,13 @@
  load-$(CONFIG_MIPS_COBALT)    += 0xffffffff80080000
  
-+# 
+ #
 +# Infineon IFXMIPS
-+# 
++#
 +core-$(CONFIG_IFXMIPS) += arch/mips/ifxmips/
 +cflags-$(CONFIG_IFXMIPS)   += -Iinclude/asm-mips/mach-ifxmips
 +load-$(CONFIG_IFXMIPS) += 0xffffffff80002000
 +
- #
++#
  # DECstation family
  #
+ core-$(CONFIG_MACH_DECSTATION)        += arch/mips/dec/
 --- a/include/asm-mips/bootinfo.h
 +++ b/include/asm-mips/bootinfo.h
 @@ -94,6 +94,12 @@
                cp0_perfcount_irq = (read_c0_intctl() >> 26) & 7;
                if (cp0_perfcount_irq == cp0_compare_irq)
                        cp0_perfcount_irq = -1;
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -48,3 +48,4 @@
+ obj-$(CONFIG_VICTOR_MPC30X)   += fixup-mpc30x.o
+ obj-$(CONFIG_ZAO_CAPCELLA)    += fixup-capcella.o
+ obj-$(CONFIG_WR_PPMC)         += fixup-wrppmc.o
++obj-$(CONFIG_IFXMIPS)         += pci-ifxmips.o ops-ifxmips.o