lots of ifxmips cleanups
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / patches / 100-board.patch
index 79d18cadc35484098811c652d826e3e0f7cd29a6..38c8fd6b013d6c871aaaef32c348dd3368811e27 100644 (file)
@@ -1,13 +1,13 @@
 Index: linux-2.6.25.7/arch/mips/Kconfig
 ===================================================================
---- linux-2.6.25.7.orig/arch/mips/Kconfig      2008-06-18 00:28:54.000000000 +0200
-+++ linux-2.6.25.7/arch/mips/Kconfig   2008-06-18 00:35:50.000000000 +0200
+--- linux-2.6.25.7.orig/arch/mips/Kconfig      2008-06-26 10:42:44.000000000 +0200
++++ linux-2.6.25.7/arch/mips/Kconfig   2008-06-26 22:05:19.000000000 +0200
 @@ -78,6 +78,21 @@
        select SYS_SUPPORTS_LITTLE_ENDIAN
        select GENERIC_HARDIRQS_NO__DO_IRQ
  
 +config IFXMIPS
-+      bool "IFXMips support"
++      bool "Infineon Twinpass, Danube, Amazon-SE"
 +      select DMA_NONCOHERENT
 +      select IRQ_CPU
 +      select CEVT_R4K
@@ -34,8 +34,8 @@ Index: linux-2.6.25.7/arch/mips/Kconfig
  
 Index: linux-2.6.25.7/arch/mips/Makefile
 ===================================================================
---- linux-2.6.25.7.orig/arch/mips/Makefile     2008-06-18 00:29:07.000000000 +0200
-+++ linux-2.6.25.7/arch/mips/Makefile  2008-06-18 00:35:42.000000000 +0200
+--- linux-2.6.25.7.orig/arch/mips/Makefile     2008-06-26 10:42:55.000000000 +0200
++++ linux-2.6.25.7/arch/mips/Makefile  2008-06-26 10:42:56.000000000 +0200
 @@ -283,6 +283,13 @@
  load-$(CONFIG_MIPS_COBALT)    += 0xffffffff80080000
  
@@ -52,8 +52,8 @@ Index: linux-2.6.25.7/arch/mips/Makefile
  core-$(CONFIG_MACH_DECSTATION)        += arch/mips/dec/
 Index: linux-2.6.25.7/include/asm-mips/bootinfo.h
 ===================================================================
---- linux-2.6.25.7.orig/include/asm-mips/bootinfo.h    2008-06-18 00:28:54.000000000 +0200
-+++ linux-2.6.25.7/include/asm-mips/bootinfo.h 2008-06-18 00:29:08.000000000 +0200
+--- linux-2.6.25.7.orig/include/asm-mips/bootinfo.h    2008-06-26 10:42:44.000000000 +0200
++++ linux-2.6.25.7/include/asm-mips/bootinfo.h 2008-06-26 10:42:56.000000000 +0200
 @@ -94,6 +94,12 @@
  #define MACH_MSP7120_FPGA       5     /* PMC-Sierra MSP7120 Emulation */
  #define MACH_MSP_OTHER        255     /* PMC-Sierra unknown board type */
@@ -69,8 +69,8 @@ Index: linux-2.6.25.7/include/asm-mips/bootinfo.h
  extern char *system_type;
 Index: linux-2.6.25.7/arch/mips/kernel/traps.c
 ===================================================================
---- linux-2.6.25.7.orig/arch/mips/kernel/traps.c       2008-06-18 00:28:54.000000000 +0200
-+++ linux-2.6.25.7/arch/mips/kernel/traps.c    2008-06-18 00:29:08.000000000 +0200
+--- linux-2.6.25.7.orig/arch/mips/kernel/traps.c       2008-06-26 10:42:44.000000000 +0200
++++ linux-2.6.25.7/arch/mips/kernel/traps.c    2008-06-26 10:42:56.000000000 +0200
 @@ -1379,6 +1379,7 @@
         */
        if (cpu_has_mips_r2) {
@@ -81,8 +81,8 @@ Index: linux-2.6.25.7/arch/mips/kernel/traps.c
                        cp0_perfcount_irq = -1;
 Index: linux-2.6.25.7/arch/mips/pci/Makefile
 ===================================================================
---- linux-2.6.25.7.orig/arch/mips/pci/Makefile 2008-06-18 00:34:49.000000000 +0200
-+++ linux-2.6.25.7/arch/mips/pci/Makefile      2008-06-18 00:35:03.000000000 +0200
+--- linux-2.6.25.7.orig/arch/mips/pci/Makefile 2008-06-26 10:42:44.000000000 +0200
++++ linux-2.6.25.7/arch/mips/pci/Makefile      2008-06-26 10:42:56.000000000 +0200
 @@ -48,3 +48,4 @@
  obj-$(CONFIG_VICTOR_MPC30X)   += fixup-mpc30x.o
  obj-$(CONFIG_ZAO_CAPCELLA)    += fixup-capcella.o