[kernel] update to 2.6.26.5 and 2.6.25.17
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / patches / 110-drivers.patch
index a2fba850325b032c328f941abb2df9386794fbcf..a25c57003abed7bf106a85fdb794f41418fbce10 100644 (file)
@@ -1,11 +1,9 @@
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
-@@ -113,6 +113,12 @@
+@@ -114,6 +114,10 @@
  obj-$(CONFIG_JS_RTC)          += js-rtc.o
  js-rtc-y = rtc.o
  
-+obj-$(CONFIG_IFXMIPS_LED)  += ifxmips_led.o
-+obj-$(CONFIG_IFXMIPS_GPIO) += ifxmips_gpio.o
 +obj-$(CONFIG_IFXMIPS_SSC)  += ifxmips_ssc.o
 +obj-$(CONFIG_IFXMIPS_EEPROM)   += ifxmips_eeprom.o
 +obj-$(CONFIG_IFXMIPS_MEI)  += ifxmips_mei_core.o
@@ -15,7 +13,7 @@
  
 --- a/drivers/mtd/maps/Makefile
 +++ b/drivers/mtd/maps/Makefile
-@@ -68,3 +68,4 @@
+@@ -67,3 +67,4 @@
  obj-$(CONFIG_MTD_OMAP_NOR)    += omap_nor.o
  obj-$(CONFIG_MTD_MTX1)                += mtx-1_flash.o
  obj-$(CONFIG_MTD_INTEL_VR_NOR)        += intel_vr_nor.o
@@ -37,7 +35,7 @@
        depends on ARM || MIPS || SUPERH
 --- a/drivers/serial/Kconfig
 +++ b/drivers/serial/Kconfig
-@@ -1327,6 +1327,14 @@
+@@ -1334,6 +1334,14 @@
          Currently, only 8250 compatible ports are supported, but
          others can easily be added.
  
        depends on QUICC_ENGINE
 --- a/drivers/serial/Makefile
 +++ b/drivers/serial/Makefile
-@@ -66,4 +66,5 @@
- obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
- obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
+@@ -68,3 +68,4 @@
  obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
-+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
+ obj-$(CONFIG_KGDB_SERIAL_CONSOLE) += kgdboc.o
  obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
++obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
 --- a/drivers/watchdog/Makefile
 +++ b/drivers/watchdog/Makefile
-@@ -96,6 +96,7 @@
+@@ -97,6 +97,7 @@
  obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
  obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
  obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
  
 --- a/drivers/net/Makefile
 +++ b/drivers/net/Makefile
-@@ -254,3 +254,4 @@
- obj-$(CONFIG_NETXEN_NIC) += netxen/
+@@ -256,4 +256,4 @@
  obj-$(CONFIG_NIU) += niu.o
  obj-$(CONFIG_VIRTIO_NET) += virtio_net.o
+ obj-$(CONFIG_SFC) += sfc/
+-
 +obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
+--- a/drivers/crypto/Kconfig
++++ b/drivers/crypto/Kconfig
+@@ -9,6 +9,9 @@
+         If you say N, all options in this submenu will be skipped and disabled.
+ if CRYPTO_HW
++config CRYPTO_DEV_IFXMIPS
++      tristate "Support for IFXMIPS Data Encryption Unit"
++      depends on IFXMIPS
+ config CRYPTO_DEV_PADLOCK
+       tristate "Support for VIA PadLock ACE"
+--- a/drivers/crypto/Makefile
++++ b/drivers/crypto/Makefile
+@@ -4,3 +4,4 @@
+ obj-$(CONFIG_CRYPTO_DEV_HIFN_795X) += hifn_795x.o
+ obj-$(CONFIG_CRYPTO_DEV_TALITOS) += talitos.o
+ obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
++obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxdeu-aes.o ifxdeu-des.o ifxdeu-dma.o ifxdeu-generic.o ifxdeu-md5.o ifxdeu-sha1.o
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -305,3 +305,10 @@
+       help
+          This driver enables support for the on-chip R8A66597 in the
+          SH7366 and SH7723 processors.
++
++config USB_DWC_HCD
++      tristate "IFXMIPS USB Host Controller Driver"
++      depends on USB && IFXMIPS 
++      default y
++      help
++       Danube USB Host Controller
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -153,6 +153,12 @@
+         To compile this driver as a module, choose M here: the
+         module will be called leds-clevo-mail.
++config LEDS_IFXMIPS
++      tristate "LED Support for IFXMIPS  LEDs"
++      depends on LEDS_CLASS && IFXMIPS
++      help
++        This option enables support for the CM-X270 LEDs.
++
+ comment "LED Triggers"
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -22,6 +22,7 @@
+ obj-$(CONFIG_LEDS_CLEVO_MAIL)         += leds-clevo-mail.o
+ obj-$(CONFIG_LEDS_HP6XX)              += leds-hp6xx.o
+ obj-$(CONFIG_LEDS_FSG)                        += leds-fsg.o
++obj-$(CONFIG_LEDS_IFXMIPS)            += leds-ifxmips.o
+ # LED Triggers
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER)      += ledtrig-timer.o
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -683,6 +683,12 @@
+       help
+         Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
++config IFXMIPS_WDT
++      bool "IFXMips watchdog"
++      depends on IFXMIPS
++      help
++        Hardware driver for the IFXMIPS Watchdog Timer.
++
+ # PARISC Architecture
+ # POWERPC Architecture