[kernel] update to 2.6.26.5 and 2.6.25.17
[openwrt/svn-archive/archive.git] / target / linux / ifxmips / patches / 110-drivers.patch
index effe6b287b6dbb76da3b5345d296798b725990ac..a25c57003abed7bf106a85fdb794f41418fbce10 100644 (file)
@@ -1,41 +1,26 @@
-Index: linux-2.6.23/drivers/serial/Kconfig
-===================================================================
---- linux-2.6.23.orig/drivers/serial/Kconfig   2007-12-22 20:21:04.563793426 +0100
-+++ linux-2.6.23/drivers/serial/Kconfig        2007-12-22 20:21:08.848037572 +0100
-@@ -1259,4 +1259,10 @@
-         Currently, only 8250 compatible ports are supported, but
-         others can easily be added.
+--- a/drivers/char/Makefile
++++ b/drivers/char/Makefile
+@@ -114,6 +114,10 @@
+ obj-$(CONFIG_JS_RTC)          += js-rtc.o
+ js-rtc-y = rtc.o
  
-+config SERIAL_IFXMIPS
-+      bool "IFXMips serial driver"
-+      depends on IFXMIPS
-+      help
-+        Driver for the ifxmipss built in ASC hardware
++obj-$(CONFIG_IFXMIPS_SSC)  += ifxmips_ssc.o
++obj-$(CONFIG_IFXMIPS_EEPROM)   += ifxmips_eeprom.o
++obj-$(CONFIG_IFXMIPS_MEI)  += ifxmips_mei_core.o
 +
- endmenu
-Index: linux-2.6.23/drivers/serial/Makefile
-===================================================================
---- linux-2.6.23.orig/drivers/serial/Makefile  2007-12-22 20:21:04.571793884 +0100
-+++ linux-2.6.23/drivers/serial/Makefile       2007-12-22 20:21:08.852037801 +0100
-@@ -64,3 +64,4 @@
- obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
- obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
- obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
-+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
-Index: linux-2.6.23/drivers/mtd/maps/Makefile
-===================================================================
---- linux-2.6.23.orig/drivers/mtd/maps/Makefile        2007-12-22 20:21:04.579794340 +0100
-+++ linux-2.6.23/drivers/mtd/maps/Makefile     2007-12-22 20:21:08.860038256 +0100
-@@ -71,3 +71,4 @@
+ # Files generated that shall be removed upon make clean
+ clean-files := consolemap_deftbl.c defkeymap.c
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -67,3 +67,4 @@
  obj-$(CONFIG_MTD_OMAP_NOR)    += omap_nor.o
  obj-$(CONFIG_MTD_MTX1)                += mtx-1_flash.o
- obj-$(CONFIG_MTD_TQM834x)     += tqm834x.o
-+obj-$(CONFIG_MTD_IFXMIPS)     += ifxmips.o
-Index: linux-2.6.23/drivers/net/Kconfig
-===================================================================
---- linux-2.6.23.orig/drivers/net/Kconfig      2007-12-22 20:21:08.035991295 +0100
-+++ linux-2.6.23/drivers/net/Kconfig   2007-12-22 20:21:08.860038256 +0100
-@@ -339,6 +339,18 @@
+ obj-$(CONFIG_MTD_INTEL_VR_NOR)        += intel_vr_nor.o
++obj-$(CONFIG_MTD_IFXMIPS)  += ifxmips.o
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -351,6 +351,12 @@
  
  source "drivers/net/arm/Kconfig"
  
@@ -45,50 +30,120 @@ Index: linux-2.6.23/drivers/net/Kconfig
 +      help
 +        Support for the MII0 inside the IFXMips SOC
 +
-+config IFXMIPS_MII1
-+      tristate "Infineon IFXMips eth1 driver"
+ config AX88796
+       tristate "ASIX AX88796 NE2000 clone support"
+       depends on ARM || MIPS || SUPERH
+--- a/drivers/serial/Kconfig
++++ b/drivers/serial/Kconfig
+@@ -1334,6 +1334,14 @@
+         Currently, only 8250 compatible ports are supported, but
+         others can easily be added.
++config SERIAL_IFXMIPS
++      bool "IFXMips serial driver"
 +      depends on IFXMIPS
++      select SERIAL_CORE
++      select SERIAL_CORE_CONSOLE
 +      help
-+        Support for the MII1 inside the IFXMips SOC
++        Driver for the ifxmipss built in ASC hardware
 +
- config AX88796
-       tristate "ASIX AX88796 NE2000 clone support"
-       depends on ARM || MIPS
-Index: linux-2.6.23/drivers/net/Makefile
-===================================================================
---- linux-2.6.23.orig/drivers/net/Makefile     2007-12-22 20:21:08.039991524 +0100
-+++ linux-2.6.23/drivers/net/Makefile  2007-12-22 20:21:08.860038256 +0100
-@@ -208,6 +208,7 @@
- obj-$(CONFIG_FEC_8XX) += fec_8xx/
- obj-$(CONFIG_PASEMI_MAC) += pasemi_mac.o
- obj-$(CONFIG_MLX4_CORE) += mlx4/
+ config SERIAL_QE
+       tristate "Freescale QUICC Engine serial port support"
+       depends on QUICC_ENGINE
+--- a/drivers/serial/Makefile
++++ b/drivers/serial/Makefile
+@@ -68,3 +68,4 @@
+ obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
+ obj-$(CONFIG_KGDB_SERIAL_CONSOLE) += kgdboc.o
+ obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
++obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -97,6 +97,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
+ # PARISC Architecture
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -256,4 +256,4 @@
+ obj-$(CONFIG_NIU) += niu.o
+ obj-$(CONFIG_VIRTIO_NET) += virtio_net.o
+ obj-$(CONFIG_SFC) += sfc/
+-
 +obj-$(CONFIG_IFXMIPS_MII0) += ifxmips_mii0.o
+--- a/drivers/crypto/Kconfig
++++ b/drivers/crypto/Kconfig
+@@ -9,6 +9,9 @@
+         If you say N, all options in this submenu will be skipped and disabled.
  
- obj-$(CONFIG_MACB) += macb.o
+ if CRYPTO_HW
++config CRYPTO_DEV_IFXMIPS
++      tristate "Support for IFXMIPS Data Encryption Unit"
++      depends on IFXMIPS
  
-Index: linux-2.6.23/drivers/char/watchdog/Makefile
-===================================================================
---- linux-2.6.23.orig/drivers/char/watchdog/Makefile   2007-12-22 20:21:04.599795479 +0100
-+++ linux-2.6.23/drivers/char/watchdog/Makefile        2007-12-22 20:21:08.880039396 +0100
-@@ -90,6 +90,7 @@
- obj-$(CONFIG_INDYDOG) += indydog.o
- obj-$(CONFIG_WDT_MTX1)        += mtx-1_wdt.o
- obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
-+obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
+ config CRYPTO_DEV_PADLOCK
+       tristate "Support for VIA PadLock ACE"
+--- a/drivers/crypto/Makefile
++++ b/drivers/crypto/Makefile
+@@ -4,3 +4,4 @@
+ obj-$(CONFIG_CRYPTO_DEV_HIFN_795X) += hifn_795x.o
+ obj-$(CONFIG_CRYPTO_DEV_TALITOS) += talitos.o
+ obj-$(CONFIG_CRYPTO_DEV_IXP4XX) += ixp4xx_crypto.o
++obj-$(CONFIG_CRYPTO_DEV_IFXMIPS) += ifxdeu-aes.o ifxdeu-des.o ifxdeu-dma.o ifxdeu-generic.o ifxdeu-md5.o ifxdeu-sha1.o
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -305,3 +305,10 @@
+       help
+          This driver enables support for the on-chip R8A66597 in the
+          SH7366 and SH7723 processors.
++
++config USB_DWC_HCD
++      tristate "IFXMIPS USB Host Controller Driver"
++      depends on USB && IFXMIPS 
++      default y
++      help
++       Danube USB Host Controller
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
+@@ -153,6 +153,12 @@
+         To compile this driver as a module, choose M here: the
+         module will be called leds-clevo-mail.
  
- # PARISC Architecture
++config LEDS_IFXMIPS
++      tristate "LED Support for IFXMIPS  LEDs"
++      depends on LEDS_CLASS && IFXMIPS
++      help
++        This option enables support for the CM-X270 LEDs.
++
+ comment "LED Triggers"
+ config LEDS_TRIGGERS
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
+@@ -22,6 +22,7 @@
+ obj-$(CONFIG_LEDS_CLEVO_MAIL)         += leds-clevo-mail.o
+ obj-$(CONFIG_LEDS_HP6XX)              += leds-hp6xx.o
+ obj-$(CONFIG_LEDS_FSG)                        += leds-fsg.o
++obj-$(CONFIG_LEDS_IFXMIPS)            += leds-ifxmips.o
  
-Index: linux-2.6.23/drivers/char/Makefile
-===================================================================
---- linux-2.6.23.orig/drivers/char/Makefile    2007-12-22 20:21:04.611796164 +0100
-+++ linux-2.6.23/drivers/char/Makefile 2007-12-24 15:04:56.849129757 +0100
-@@ -135,3 +135,9 @@
-       rm $@.tmp
+ # LED Triggers
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER)      += ledtrig-timer.o
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -683,6 +683,12 @@
+       help
+         Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
  
- endif
++config IFXMIPS_WDT
++      bool "IFXMips watchdog"
++      depends on IFXMIPS
++      help
++        Hardware driver for the IFXMIPS Watchdog Timer.
 +
-+obj-$(CONFIG_IFXMIPS_LED)     += ifxmips_led.o
-+obj-$(CONFIG_IFXMIPS_GPIO)    += ifxmips_gpio.o
-+obj-$(CONFIG_IFXMIPS_SSC)     += ifxmips_ssc.o
-+obj-$(CONFIG_IFXMIPS_EEPROM)  += ifxmips_eeprom.o
-+obj-$(CONFIG_IFXMIPS_MEI)     += ifxmips_mei_core.o ifxmips_mei_bsp.c ifxmips_mei_mib.c
+ # PARISC Architecture
+ # POWERPC Architecture