fix accidentally committed typo
[openwrt/svn-archive/archive.git] / target / linux / iop32x / Makefile
index c097955f3433de1427100f978d8a12cbb7d3281b..2fe245b50b117c919a7dd3a703cc6182f4f07bbe 100644 (file)
@@ -8,14 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=iop32x
-BOARDNAME:=Intel XScale IOP32x
+BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.26.5
 
 include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
 
 $(eval $(call BuildTarget))