[kernel] update to 2.6.32.29
[openwrt/svn-archive/archive.git] / target / linux / iop32x / Makefile
index e46e0c80c8bb2fc0fdd3a3fa9cc90d20ae156ea9..727a12985789271a6950e8f691c9b9a8a7c2230e 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=iop32x
 BOARDNAME:=Intel IOP32x
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.26.3
+LINUX_VERSION:=2.6.32.29
 
 include $(INCLUDE_DIR)/target.mk
 
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
-
 $(eval $(call BuildTarget))