ixp4xx-2.6/nslu2: Added support for building 16MB images
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx-2.6 / image / Makefile
index 617bc15c20304b636d59106542fc0fe4ff0e4385..70ff0ebf56a692ecf7fa6dda3ef093a62a8d02a1 100644 (file)
@@ -7,15 +7,38 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+UCODEFILE:=IPL_ixp400NpeLibrary-2_4.zip
+
+ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
+  define Require/npe-ucode
+       [ -f $(DL_DIR)/$(UCODEFILE) ]
+  endef
+  define Build/Compile/npe
+       $(MAKE) -C npe-ucode \
+               BUILD_DIR="$(KDIR)" \
+               TARGET="$(KDIR)" \
+               compile
+  endef
+  define Image/Build/slug
+       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+               -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+               -F -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1)-16mb.bin
+  endef
+endif
+
 define Build/Compile
        $(MAKE) -C apex \
                BUILD_DIR="$(KDIR)" \
                TARGET="$(KDIR)" \
                compile 
-       $(MAKE) -C npe-ucode \
-               BUILD_DIR="$(KDIR)" \
-               TARGET="$(KDIR)" \
-               compile
+       $(call Build/Compile/npe)
 endef
 
 define Build/Clean
@@ -37,14 +60,6 @@ define Image/Build
        $(call Image/Build/$(1),$(1))
 endef
 
-define Image/Build/slug
-       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
-               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-               -r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
-endef
-
 define Image/Build/jffs2-64k
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
 endef
@@ -62,16 +77,9 @@ endef
 
 $(eval $(call BuildImage))
 
-UCODEFILE:=IPL_ixp400NpeLibrary-2_3.zip
-
-define Require/npe-ucode
-       [ -f $(DL_DIR)/$(UCODEFILE) ]
-endef
-
 $(eval $(call Require,npe-ucode, \
        You must manually download $(UCODEFILE) from \\\
-       http://www.intel.com/design/network/products/npfamily/ixp400_current.htm \\\
+       http://www.intel.com/design/network/products/npfamily/ixp400_archives.htm \\\
        and put it in $(DL_DIR). \\\
        You will need to agree to the Intel Public License to do so - please do read it! \
 ))
-