apex: Updated to version 1.5.4
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx-2.6 / image / Makefile
index 9359c5b11e9195ffb7e2fce986f867e630580c28..7d230028530e0aed60824ff32150b61eeeb20632 100644 (file)
@@ -11,11 +11,11 @@ define Build/Compile
        $(MAKE) -C apex \
                BUILD_DIR="$(KDIR)" \
                TARGET="$(KDIR)" \
-               install
+               compile 
        $(MAKE) -C npe-ucode \
                BUILD_DIR="$(KDIR)" \
                TARGET="$(KDIR)" \
-               install
+               compile
 endef
 
 define Build/Clean
@@ -24,10 +24,11 @@ define Build/Clean
 endef
 
 define Image/Prepare
+       cp $(LINUX_DIR)/arch/arm/boot/zImage $(KDIR)/zImage
 endef
 
 define Image/BuildKernel
-       cp $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
+       cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
 #      $(shell BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh)
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
 endef
@@ -36,17 +37,40 @@ define Image/Build
        $(call Image/Build/$(1),$(1))
 endef
 
+define Image/Build/slug
+       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+               -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+endef
+
 define Image/Build/jffs2-64k
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
 endef
 
 define Image/Build/jffs2-128k
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
-       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
-               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-               -r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+       $(call Image/Build/slug,$(1))
+endef
+
+define Image/Build/squashfs
+    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+       $(call Image/Build/slug,$(1))
 endef
 
 $(eval $(call BuildImage))
+
+UCODEFILE:=IPL_ixp400NpeLibrary-2_4.zip
+
+define Require/npe-ucode
+       [ -f $(DL_DIR)/$(UCODEFILE) ]
+endef
+
+$(eval $(call Require,npe-ucode, \
+       You must manually download $(UCODEFILE) from \\\
+       http://www.intel.com/design/network/products/npfamily/ixp400_archives.htm \\\
+       and put it in $(DL_DIR). \\\
+       You will need to agree to the Intel Public License to do so - please do read it! \
+))