apex: Updated to version 1.5.4
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx-2.6 / image / Makefile
index 9a259aa82ae909ee107a17a7273bf89edfc52fbb..7d230028530e0aed60824ff32150b61eeeb20632 100644 (file)
@@ -41,7 +41,7 @@ define Image/Build/slug
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
                -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
                -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-               -r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
                -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
 endef
 
@@ -62,7 +62,7 @@ endef
 
 $(eval $(call BuildImage))
 
-UCODEFILE:=IPL_ixp400NpeLibrary-2_3_2.zip
+UCODEFILE:=IPL_ixp400NpeLibrary-2_4.zip
 
 define Require/npe-ucode
        [ -f $(DL_DIR)/$(UCODEFILE) ]
@@ -70,7 +70,7 @@ endef
 
 $(eval $(call Require,npe-ucode, \
        You must manually download $(UCODEFILE) from \\\
-       http://www.intel.com/design/network/products/npfamily/ixp400_current.htm \\\
+       http://www.intel.com/design/network/products/npfamily/ixp400_archives.htm \\\
        and put it in $(DL_DIR). \\\
        You will need to agree to the Intel Public License to do so - please do read it! \
 ))