Unmark as broken
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx-2.6 / image / Makefile
index cbbb29b6b98455858186f35df3073e42ebf2b384..8d05a1b8f1294c0dd5f6e21c1e4ff21f18889c18 100644 (file)
@@ -7,15 +7,33 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Compile
-       $(MAKE) -C apex \
+UCODEFILE:=IPL_ixp400NpeLibrary-2_4.zip
+
+ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
+  define Require/npe-ucode
+       [ -f $(DL_DIR)/$(UCODEFILE) ]
+  endef
+  define Build/Compile/npe
+       $(MAKE) -C npe-ucode \
                BUILD_DIR="$(KDIR)" \
                TARGET="$(KDIR)" \
-               install
-       $(MAKE) -C npe-ucode \
+               compile
+  endef
+  define Image/Build/slug
+       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
+               -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
+               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
+               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+  endef
+endif
+
+define Build/Compile
+       $(MAKE) -C apex \
                BUILD_DIR="$(KDIR)" \
                TARGET="$(KDIR)" \
-               install
+               compile 
+       $(call Build/Compile/npe)
 endef
 
 define Build/Clean
@@ -43,11 +61,20 @@ endef
 
 define Image/Build/jffs2-128k
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
-       BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
-               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-               -r Flashdisk:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+       $(call Image/Build/slug,$(1))
+endef
+
+define Image/Build/squashfs
+    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+       $(call Image/Build/slug,$(1))
 endef
 
 $(eval $(call BuildImage))
+
+$(eval $(call Require,npe-ucode, \
+       You must manually download $(UCODEFILE) from \\\
+       http://www.intel.com/design/network/products/npfamily/ixp400_archives.htm \\\
+       and put it in $(DL_DIR). \\\
+       You will need to agree to the Intel Public License to do so - please do read it! \
+))