[kernel] update to 2.6.28.2
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / Makefile
index 5ef4c8ce2031d58c98112ade063a15dcb20f6189..6a7ba81c4636e67d40b40b890920a1c48a7495ad 100644 (file)
@@ -8,14 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=armeb
 BOARD:=ixp4xx
-BOARDNAME:=Intel XScale IXP4xx
+BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.28.2
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += ixp4xx-microcode
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
+DEFAULT_PACKAGES += ixp4xx-microcode fconfig
 
 $(eval $(call BuildTarget))