[kernel] update to 2.6.28.2
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / Makefile
index 79043d75c36295271e7e04415dbcced42ae613fb..6a7ba81c4636e67d40b40b890920a1c48a7495ad 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=armeb
 BOARD:=ixp4xx
-BOARDNAME:=Intel XScale IXP4xx
+BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.21.7
+LINUX_VERSION:=2.6.28.2
 
 include $(INCLUDE_DIR)/target.mk
 
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
+DEFAULT_PACKAGES += ixp4xx-microcode fconfig
+
 $(eval $(call BuildTarget))