[kernel] update to 2.6.26.5 and 2.6.25.17
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / Makefile
index 25b60a47b720fe3c96c4b7be6d6802b9d885ea27..9bae182b21bb25069c7bd751a96fd43d8c9d2960 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=armeb
 BOARD:=ixp4xx
-BOARDNAME:=Intel XScale IXP4xx
+BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
+SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.21.6
+LINUX_VERSION:=2.6.26.5
 
-define Target/Description
-endef
+include $(INCLUDE_DIR)/target.mk
 
-include $(INCLUDE_DIR)/kernel-build.mk
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
 
-# include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += ixp4xx-microcode fconfig
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))