add eabi autoselection for the kernel as well - fixes iptables problems
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / Makefile
index ec931a0a991a02833262b34534ff75776943ea95..eec8d13f724aa69ebdef4183d5c222000ac7da00 100644 (file)
@@ -16,6 +16,12 @@ LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
 DEFAULT_PACKAGES += ixp4xx-microcode
 
 $(eval $(call BuildTarget))