[ixp4xx] refresh kernel patches
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / patches-2.6.24 / 120-compex_support.patch
index c029ceda1b1152f7b8bf22a4a1d8aa22c1784d57..9dd5fe7855e24a2ece0c80b0fcb795893addb434 100644 (file)
@@ -1,8 +1,8 @@
-Index: linux-2.6.24/arch/arm/mach-ixp4xx/Kconfig
+Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/Kconfig
 ===================================================================
---- linux-2.6.24.orig/arch/arm/mach-ixp4xx/Kconfig     2008-03-12 21:21:26.000000000 +1030
-+++ linux-2.6.24/arch/arm/mach-ixp4xx/Kconfig  2008-03-12 21:21:26.000000000 +1030
-@@ -65,6 +65,14 @@
+--- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/Kconfig
++++ linux-2.6.24.7/arch/arm/mach-ixp4xx/Kconfig
+@@ -65,6 +65,14 @@ config MACH_PRONGHORNMETRO
          Engineering Pronghorn Metro Platform. For more
          information on this platform, see <file:Documentation/arm/IXP4xx>.
  
@@ -17,11 +17,11 @@ Index: linux-2.6.24/arch/arm/mach-ixp4xx/Kconfig
  config ARCH_IXDP425
        bool "IXDP425"
        help
-Index: linux-2.6.24/arch/arm/mach-ixp4xx/Makefile
+Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/Makefile
 ===================================================================
---- linux-2.6.24.orig/arch/arm/mach-ixp4xx/Makefile    2008-03-12 21:21:26.000000000 +1030
-+++ linux-2.6.24/arch/arm/mach-ixp4xx/Makefile 2008-03-12 21:21:26.000000000 +1030
-@@ -17,6 +17,7 @@
+--- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/Makefile
++++ linux-2.6.24.7/arch/arm/mach-ixp4xx/Makefile
+@@ -17,6 +17,7 @@ obj-pci-$(CONFIG_MACH_GATEWAY7001)   += ga
  obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
  obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
  obj-pci-$(CONFIG_MACH_PRONGHORNMETRO) += pronghornmetro-pci.o
@@ -29,17 +29,17 @@ Index: linux-2.6.24/arch/arm/mach-ixp4xx/Makefile
  
  obj-y += common.o
  
-@@ -32,5 +33,6 @@
+@@ -32,5 +33,6 @@ obj-$(CONFIG_MACH_GATEWAY7001)       += gatewa
  obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
  obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
  obj-$(CONFIG_MACH_PRONGHORNMETRO)     += pronghornmetro-setup.o
 +obj-$(CONFIG_MACH_COMPEX)     += compex-setup.o
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
-Index: linux-2.6.24/arch/arm/mach-ixp4xx/compex-setup.c
+Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/compex-setup.c
 ===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.24/arch/arm/mach-ixp4xx/compex-setup.c   2008-03-12 21:21:26.000000000 +1030
+--- /dev/null
++++ linux-2.6.24.7/arch/arm/mach-ixp4xx/compex-setup.c
 @@ -0,0 +1,120 @@
 +/*
 + * arch/arm/mach-ixp4xx/compex-setup.c
@@ -161,11 +161,11 @@ Index: linux-2.6.24/arch/arm/mach-ixp4xx/compex-setup.c
 +      .init_machine   = compex_init,
 +MACHINE_END
 +#endif
-Index: linux-2.6.24/arch/arm/mach-ixp4xx/ixdp425-pci.c
+Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/ixdp425-pci.c
 ===================================================================
---- linux-2.6.24.orig/arch/arm/mach-ixp4xx/ixdp425-pci.c       2008-03-12 21:20:48.000000000 +1030
-+++ linux-2.6.24/arch/arm/mach-ixp4xx/ixdp425-pci.c    2008-03-12 21:21:26.000000000 +1030
-@@ -66,7 +66,7 @@
+--- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/ixdp425-pci.c
++++ linux-2.6.24.7/arch/arm/mach-ixp4xx/ixdp425-pci.c
+@@ -66,7 +66,7 @@ struct hw_pci ixdp425_pci __initdata = {
  int __init ixdp425_pci_init(void)
  {
        if (machine_is_ixdp425() || machine_is_ixcdp1100() ||
@@ -174,11 +174,11 @@ Index: linux-2.6.24/arch/arm/mach-ixp4xx/ixdp425-pci.c
                pci_common_init(&ixdp425_pci);
        return 0;
  }
-Index: linux-2.6.24/arch/arm/tools/mach-types
+Index: linux-2.6.24.7/arch/arm/tools/mach-types
 ===================================================================
---- linux-2.6.24.orig/arch/arm/tools/mach-types        2008-03-12 21:20:48.000000000 +1030
-+++ linux-2.6.24/arch/arm/tools/mach-types     2008-03-12 21:21:26.000000000 +1030
-@@ -1278,7 +1278,7 @@
+--- linux-2.6.24.7.orig/arch/arm/tools/mach-types
++++ linux-2.6.24.7/arch/arm/tools/mach-types
+@@ -1276,7 +1276,7 @@ oiab                     MACH_OIAB               OIAB                    1269
  smdk6400              MACH_SMDK6400           SMDK6400                1270
  nokia_n800            MACH_NOKIA_N800         NOKIA_N800              1271
  greenphone            MACH_GREENPHONE         GREENPHONE              1272