refresh ixp4xx patches to match upstream style
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / patches-2.6.25 / 110-pronghorn_metro_support.patch
index 3f8094daa799f1ead2d8bc243006345336fdbfbb..6908a28adb937b5d186e6c78dab91aa2bda6c563 100644 (file)
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Kconfig
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
-@@ -57,6 +57,14 @@ config MACH_WG302V2
+--- a/arch/arm/mach-ixp4xx/Kconfig
++++ b/arch/arm/mach-ixp4xx/Kconfig
+@@ -57,6 +57,14 @@
          WG302 v2 or WAG302 v2 Access Points. For more information
          on this platform, see http://openwrt.org
  
@@ -17,11 +15,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Kconfig
  config ARCH_IXDP425
        bool "IXDP425"
        help
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.25.4.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
-@@ -16,6 +16,7 @@ obj-pci-$(CONFIG_MACH_DSMG600)               += dsmg6
+--- a/arch/arm/mach-ixp4xx/Makefile
++++ b/arch/arm/mach-ixp4xx/Makefile
+@@ -16,6 +16,7 @@
  obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
  obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
  obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
@@ -29,7 +25,7 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
  
  obj-y += common.o
  
-@@ -30,6 +31,7 @@ obj-$(CONFIG_MACH_DSMG600)      += dsmg6
+@@ -30,6 +31,7 @@
  obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
  obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
  obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
@@ -37,10 +33,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/Makefile
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
  obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/pronghornmetro-pci.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/pronghornmetro-pci.c
++++ b/arch/arm/mach-ixp4xx/pronghornmetro-pci.c
 @@ -0,0 +1,74 @@
 +/*
 + * arch/arch/mach-ixp4xx/pronghornmetro-pci.c
@@ -116,10 +110,8 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/pronghornmetro-pci.c
 +}
 +
 +subsys_initcall(pronghornmetro_pci_init);
-Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/pronghornmetro-setup.c
-===================================================================
 --- /dev/null
-+++ linux-2.6.25.4/arch/arm/mach-ixp4xx/pronghornmetro-setup.c
++++ b/arch/arm/mach-ixp4xx/pronghornmetro-setup.c
 @@ -0,0 +1,147 @@
 +/*
 + * arch/arm/mach-ixp4xx/pronghornmetro-setup.c
@@ -268,11 +260,9 @@ Index: linux-2.6.25.4/arch/arm/mach-ixp4xx/pronghornmetro-setup.c
 +      .init_machine   = pronghornmetro_init,
 +MACHINE_END
 +#endif
-Index: linux-2.6.25.4/Documentation/arm/IXP4xx
-===================================================================
---- linux-2.6.25.4.orig/Documentation/arm/IXP4xx
-+++ linux-2.6.25.4/Documentation/arm/IXP4xx
-@@ -111,6 +111,9 @@ http://www.adiengineering.com/productsCo
+--- a/Documentation/arm/IXP4xx
++++ b/Documentation/arm/IXP4xx
+@@ -111,6 +111,9 @@
     the platform has two mini-PCI slots used for 802.11[bga] cards.
     Finally, there is an IDE port hanging off the expansion bus.
  
@@ -282,11 +272,9 @@ Index: linux-2.6.25.4/Documentation/arm/IXP4xx
  Gateworks Avila Network Platform
  http://www.gateworks.com/avila_sbc.htm
  
-Index: linux-2.6.25.4/include/asm-arm/arch-ixp4xx/uncompress.h
-===================================================================
---- linux-2.6.25.4.orig/include/asm-arm/arch-ixp4xx/uncompress.h
-+++ linux-2.6.25.4/include/asm-arm/arch-ixp4xx/uncompress.h
-@@ -41,7 +41,8 @@ static __inline__ void __arch_decomp_set
+--- a/include/asm-arm/arch-ixp4xx/uncompress.h
++++ b/include/asm-arm/arch-ixp4xx/uncompress.h
+@@ -41,7 +41,8 @@
         * Some boards are using UART2 as console
         */
        if (machine_is_adi_coyote() || machine_is_gtwx5715() ||