kirkwood: generate factory images for Linksys EA[34]500
[openwrt/svn-archive/archive.git] / target / linux / kirkwood / profiles / 115-router.mk
index 89a5bd435afc9f42ff677001ae11fb38ed19c27c..c01bef7020010cce34055d0f64b455bc60f47c9e 100644 (file)
@@ -5,18 +5,28 @@
 # See /LICENSE for more information.
 #
 
+define Profile/EA3500
+  NAME:=Linksys EA3500
+  PACKAGES:= \
+       kmod-mwl8k kmod-usb2 kmod-usb-storage \
+       swconfig wpad-mini
+endef
+
+define Profile/EA3500/Description
+ Package set compatible with Linksys EA3500 board.
+endef
+
+$(eval $(call Profile,EA3500))
+
 define Profile/EA4500
   NAME:=Linksys EA4500
   PACKAGES:= \
        kmod-mwl8k kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       swconfig wpad-mini
 endef
 
 define Profile/EA4500/Description
  Package set compatible with Linksys EA4500 board.
 endef
 
-EA4500_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
-EA4500_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
-
-# $(eval $(call Profile,EA4500))
+$(eval $(call Profile,EA4500))