kernel: update linux 3.8 to 3.8.11
[openwrt/svn-archive/archive.git] / target / linux / lantiq / Makefile
index 412b7b19c66ed3ac83e4696bf1b0c80391f5694c..2e6573d3dd122318a1b27881f39fe0373394fe42 100644 (file)
@@ -6,21 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway ase
+SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=2.6.39
-#LINUX_VERSION:=2.6.32.33
+LINUX_VERSION:=3.8.11
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))