kernel: update linux 3.8 to 3.8.12
[openwrt/svn-archive/archive.git] / target / linux / lantiq / Makefile
index 9623a0b4e5f53d2406b9b7ee7d990487278a005d..53cbc30c0f147f5a4aa536c6291ae2965e3e3599 100644 (file)
@@ -6,15 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.2.14
+LINUX_VERSION:=3.8.12
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC