kernel: update linux 3.7 to 3.7.7
[openwrt/svn-archive/archive.git] / target / linux / lantiq / Makefile
index f9a4e0f9a4e965e858e839e6258809ba648e6985..650b90f70259a55169b022c54502a0bf9489960f 100644 (file)
@@ -1,25 +1,24 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway
+SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=2.6.37.2
+LINUX_VERSION:=3.7.7
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-
-include $(INCLUDE_DIR)/target.mk
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))