replace all references to xway with danube
[openwrt/svn-archive/archive.git] / target / linux / lantiq / Makefile
index 5afe5662da8fe4c6aa010e597fff12de22d99ed2..82e5c3926a51e0eb09d220f0d6e5f04dcf8f3937 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2 atm
-SUBTARGETS:=xway
+FEATURES:=squashfs jffs2
+DEFAULT_SUBTARGET:=danube
 
-LINUX_VERSION:=2.6.35.9
+LINUX_VERSION:=2.6.39.2
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-
-include $(INCLUDE_DIR)/target.mk
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))