[package] 6to4: support multiple internal networks, use state vars for radvd config
[openwrt/svn-archive/archive.git] / target / linux / mpc83xx / patches-2.6.33 / 019-powerpc_create_fit_uImages.patch
index 52899ce71442a37f9d8321c954e1e9399c640cb4..251a05372c856d34b3fa385f4e5d1a16ceabaaf5 100644 (file)
@@ -30,7 +30,7 @@
  treeImage.*
 --- a/arch/powerpc/boot/Makefile
 +++ b/arch/powerpc/boot/Makefile
-@@ -308,6 +308,9 @@ $(obj)/zImage.iseries: vmlinux
+@@ -311,6 +311,9 @@ $(obj)/zImage.iseries: vmlinux
  $(obj)/uImage: vmlinux $(wrapperbits)
        $(call if_changed,wrap,uboot)
  
@@ -40,7 +40,7 @@
  $(obj)/cuImage.initrd.%: vmlinux $(obj)/%.dtb $(wrapperbits)
        $(call if_changed,wrap,cuboot-$*,,$(obj)/$*.dtb,$(obj)/ramdisk.image.gz)
  
-@@ -347,7 +350,7 @@ install: $(CONFIGURE) $(addprefix $(obj)
+@@ -350,7 +353,7 @@ install: $(CONFIGURE) $(addprefix $(obj)
  
  # anything not in $(targets)
  clean-files += $(image-) $(initrd-) cuImage.* dtbImage.* treeImage.* \
      # miboot and U-boot want just the bare bits, not an ELF binary
      ext=bin
      objflags="-O binary"
-@@ -273,6 +276,21 @@ uboot)
+@@ -275,6 +278,21 @@ uboot)
+     if [ -z "$cacheit" ]; then
+       rm -f "$vmz"
      fi
-     exit 0
-     ;;
++    exit 0
++    ;;
 +uboot.fit)
 +    rm -f "$ofile"
 +    ${MKITS} -A ppc -C gzip -a $membase -e $membase -v $version \
@@ -87,8 +89,6 @@
 +    if [ -z "$cacheit" ]; then
 +      rm -f "$vmz"
 +    fi
-+    exit 0
-+    ;;
+     exit 0
+     ;;
  esac
- addsec() {