mpc85xx: enable ath9k and wpad-mini by default
[openwrt/svn-archive/archive.git] / target / linux / mpc85xx / Makefile
index 35434388679792dcb85391906f4b21380fcb7ec0..47263c4cb7fc77db5a52761cb26a27e0b3a1b2f2 100644 (file)
@@ -10,13 +10,18 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.38.8
+LINUX_VERSION:=3.8.3
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef