mpc85xx: enable ath9k and wpad-mini by default
[openwrt/svn-archive/archive.git] / target / linux / mpc85xx / Makefile
index 3bfbf6cf22065e84a4fc36291fefa886162a7902..47263c4cb7fc77db5a52761cb26a27e0b3a1b2f2 100644 (file)
@@ -10,14 +10,17 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk broken
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.7
+LINUX_VERSION:=3.8.3
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-booke-wdt
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
 
 define Target/Description
        Build images for the Freescale MPC85xx based boards.