[kernel] fill maintainer infos for a couple of targets
[openwrt/svn-archive/archive.git] / target / linux / octeon / Makefile
index b5b2e35e913c89c5574f22a7b6e2c6b2882e03b6..e05cc7d9a67600f9db849d9ebe682bff94fa2082 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,14 @@ ARCH:=mips
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
 FEATURES:=squashfs jffs2 pci usb
-CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
+CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.37.6
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini
+DEFAULT_PACKAGES += wpad-mini
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.