omap: complete 3.18 support
[openwrt/svn-archive/archive.git] / target / linux / omap / Makefile
index 78361fc3032a64c13bc10085e8f1c2023e0d34c8..03a2c244e49147860ff755e40d87443f19b9ba04 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012-2013 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,24 +9,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb targz audio display
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.12
+KERNEL_PATCHVER:=3.13
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-KERNELNAME:="zImage dtbs"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+include $(INCLUDE_DIR)/target.mk
 
-DEVICE_TYPE=developerboard
+DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
 
 define Target/Description
        TI OMAP boards
 endef
 
-include $(INCLUDE_DIR)/target.mk
-
 $(eval $(call BuildTarget))