[gumstix] Add support for ubifs
[openwrt/svn-archive/archive.git] / target / linux / omap35xx / image / Makefile
index adaf395b70d282899c4275f5f40e0b464ece60cd..e238c48af883af81fb7276a868ef25cf19a4f4a1 100644 (file)
@@ -10,9 +10,12 @@ include $(INCLUDE_DIR)/image.mk
 JFFS2_BLOCKSIZE=128k
 JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
 
+UBIFS_OPTS = -m 2048 -e 126KiB -c 1996
+UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
+
 define Image/BuildKernel
        $(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux linux.bin
-       mkimage -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n "OpenWRT Kernel Image beagleboard" -d linux.bin uImage
+       mkimage -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n "OpenWRT Kernel Image gumstix" -d linux.bin uImage
        mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'uImage.bin+mmc2' -d ../files/boot-mmc.cmd boot.scr
 
        mv uImage $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-uImage
@@ -20,11 +23,13 @@ define Image/BuildKernel
        rm linux.bin
 endef
 
+ifndef CONFIG_TARGET_omap35xx_gumstix
 define Image/Build
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-root.$(1)
        PADDING="true" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image 4 $(KDIR)/root.bootscript 240 $(KDIR)/root.$(1)
        $(call Image/Build/$(1),$(1))
 endef
+endif
 
 ifdef CONFIG_TARGET_omap35xx_gumstix
 define Image/Prepare