orion: drop DECLARE_MAC_BUF usage from the DT2 support file
[openwrt/svn-archive/archive.git] / target / linux / orion / Makefile
index a259c54e27731d1f6caf7aba357a2a6d9cadb2fa..196e93f844cf94f77d396ae7571373e70cbf1db5 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,19 +10,15 @@ ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
+SUBTARGETS=generic harddisk
+CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.28-rc7
+LINUX_VERSION:=2.6.32.9
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="uImage"
 
-DEFAULT_PACKAGES += kmod-ath9k-new hostapd-mini
-
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
+DEFAULT_PACKAGES += kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))