update to latest 2.6.27 and 2.6.30 kernels
[openwrt/svn-archive/archive.git] / target / linux / orion / Makefile
index 43db0b9f7340b90a2873aa94728539810c90e0f3..719f71070ed9483ab2e6fe3570452454dd659eda 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,19 +10,14 @@ ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
+SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.28.6
+LINUX_VERSION:=2.6.30.7
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="uImage"
 
-DEFAULT_PACKAGES += kmod-ath9k-new hostapd-mini
-
-define Kernel/Configure
-       $(call Kernel/Configure/Default)
-       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
-       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
-endef
+DEFAULT_PACKAGES += kmod-ath9k hostapd-mini
 
 $(eval $(call BuildTarget))