orion: disable CONFIG_VM_EVENT_COUNTERS by default
[openwrt/svn-archive/archive.git] / target / linux / orion / Makefile
index 48fe61bdcc6926b7301af6bf9af19eb55e830aa8..b1d109a1f694bcab2a285badee01a57bb6c5f426 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
-FEATURES:=squashfs
-SUBTARGETS=generic harddisk
+SUBTARGETS:=generic harddisk
+CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=3.3.8
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="uImage"
 
-DEFAULT_PACKAGES += kmod-ath9k hostapd-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini kmod-i2c-core kmod-i2c-mv64xxx kmod-rtc-isl1208
 
 $(eval $(call BuildTarget))