[orion] fix Freecom DT2 jffs2 rootfs generation issue (#7584)
[openwrt/svn-archive/archive.git] / target / linux / orion / Makefile
index 2e2727ff14089cd7410ac786ca267e113e1f171f..d174be419bf11844e33906efde058e35b970495a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2008 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,15 @@ ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
+SUBTARGETS=generic harddisk
+CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=2.6.34.1
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="uImage"
 
-DEFAULT_PACKAGES += kmod-ath9k-new hostapd-mini
+DEFAULT_PACKAGES += kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))