[cleanup] remove 'svn:executable' property
[openwrt/svn-archive/archive.git] / target / linux / orion / Makefile
index 48fe61bdcc6926b7301af6bf9af19eb55e830aa8..ea7cee3a709b3bf20b7d424630940caf66aca8a5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,13 +11,14 @@ BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
+CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.30.9
+LINUX_VERSION:=2.6.32.10
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="uImage"
 
-DEFAULT_PACKAGES += kmod-ath9k hostapd-mini
+DEFAULT_PACKAGES += kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))