linux: update 3.0 to 3.0.12
[openwrt/svn-archive/archive.git] / target / linux / ppc40x / Makefile
index b081849db803dc646fa6b425f6e6518e4ec6dd4e..6164d9ddc1c000326b275eb9c8e422a31990993e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,16 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=ppc40x
-BOARDNAME:=AMCC Kilauea
+BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.24.2
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=3.0.12
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Kilauea evaluation board
+       Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
 $(eval $(call BuildTarget))