[kernel] update to 2.6.30.6, compile tested on some targets only
[openwrt/svn-archive/archive.git] / target / linux / ppc40x / Makefile
index 6e66904fa8768d1f690597aae55ffde71911c8bd..ce63d3800b67558267394966f6019d7be30f23c2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs
+FEATURES:=squashfs usb
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 
-LINUX_VERSION:=2.6.26.8
+LINUX_VERSION:=2.6.30.6
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Kilauea evaluation board
+       Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
 $(eval $(call BuildTarget))