ppc4xx optimizations
[openwrt/svn-archive/archive.git] / target / linux / ppc40x / Makefile
index 163e5add9530bc995a8ce47d51613b628e5cff77..f4423391a56ab47bd41006219422319144517cfc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs
+FEATURES:=squashfs usb
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.27.7
+LINUX_VERSION:=2.6.30.3
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Kilauea evaluation board
+       Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
 $(eval $(call BuildTarget))