ppc44x: upgrade and switch to 3.18
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index 00d44dd0596f48035f0aa76f506abcbacf8b305c..17a3f5893ae145467206ea636ffff46b6de761ea 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,17 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CPU_TYPE:=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.28.8
-LINUX_KARCH:=powerpc
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+KERNELNAME:=uImage cuImage.taishan
+
 $(eval $(call BuildTarget))