kernel: update 3.10 to 3.10.28
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index fc50bcd7d96fb99abd1b7d5181e81fa1b362c2ed..2f3cac730efc8aa47aaf1feb6c1a5ff3133149b4 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+FEATURES:=squashfs broken
+CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.10.28
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -23,4 +23,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+KERNELNAME:="uImage cuImage.taishan"
+
 $(eval $(call BuildTarget))