ar71xx: improve 2.6.36 compatibility. also, instead of adding a forward port patch...
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index 1a2e1fb7732f34ca4ee1cc48c76a21272a9725d9..32a198f2d8ff7ea5e4a390653d685046bc0ed98c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,14 +10,14 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.28.6
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=2.6.32.24
 
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))