kernel: update linux 3.2 to 3.2.12
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index 9b952f12e595a119c63171733cd578578ad2b465..35addf25da33a80a0dcdbfe96886378a71b2414a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,12 +10,15 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.28.10
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=3.2.12
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
+
 define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef