update to latest 2.6.27 and 2.6.30 kernels
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index fa8ec11ea42d89c6d83825dd61be84f03224a0ca..40fe4336638881f135d13fac293f9c8be56aff78 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,16 +10,15 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.30.7
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
-
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))