targets: prepare for supporting normal and initramfs images
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index c2dee41aff8ae3c63d9fd3ccac2324bfe5c47a7b..45512b55cc7079cf3eba55d3d3f4a835bd25c4d8 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,20 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
-FEATURES:=squashfs
+FEATURES:=squashfs broken
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.27.9
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
 
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+KERNELNAME:="uImage cuImage.taishan"
+
 $(eval $(call BuildTarget))