[adm5120] cleanup files using checkpatch.pl
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index 7e7061265b0a90741cff8613e00a5436eb90f12e..b13261a9d2ba8055b4117ed87e78be43a9c030f8 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=ppc44x
-BOARDNAME:=AMCC Taishan
+BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.24.2
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=2.6.32.33
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
-
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))