ixp4xx: add kernel 2.6.35 preliminary support
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index c2dee41aff8ae3c63d9fd3ccac2324bfe5c47a7b..baa23dc54f009b796d95bcefaeaafebfa2f4c8d4 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,16 +10,14 @@ ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.27.9
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=2.6.32.14
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
-
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))