ppc44x: switch to 3.7
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index a5ca07d0eccb6a1ab6a78fec01d813f4ecd413fa..cf57b79f31a48ca9262b202b1473bd1cbe183d2a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
-FEATURES:=squashfs
+FEATURES:=squashfs broken
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.28.5
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=3.7.2
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
+
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))